Add games
This commit is contained in:
parent
3d1c1262e2
commit
562b96c4ac
11 changed files with 149 additions and 0 deletions
|
@ -1,2 +1,5 @@
|
|||
source "$BR2_EXTERNAL_BUSINESSCARD_PATH/package/sunxi-tools-f1c100s/Config.in.host"
|
||||
source "$BR2_EXTERNAL_BUSINESSCARD_PATH/package/sunxi-tools-f1c100s/Config.in"
|
||||
source "$BR2_EXTERNAL_BUSINESSCARD_PATH/package/2048/Config.in"
|
||||
source "$BR2_EXTERNAL_BUSINESSCARD_PATH/package/robotfindskitten/Config.in"
|
||||
source "$BR2_EXTERNAL_BUSINESSCARD_PATH/package/rogue/Config.in"
|
||||
|
|
|
@ -60,3 +60,6 @@ BR2_PACKAGE_HOST_MKPASSWD=y
|
|||
BR2_PACKAGE_HOST_MTD=y
|
||||
BR2_PACKAGE_HOST_MTOOLS=y
|
||||
BR2_PACKAGE_HOST_SUNXI_TOOLS_F1C100S=y
|
||||
BR2_PACKAGE_2048=y
|
||||
BR2_PACKAGE_ROBOTFINDSKITTEN=y
|
||||
BR2_PACKAGE_ROGUE=y
|
||||
|
|
21
package/2048/2048.mk
Normal file
21
package/2048/2048.mk
Normal file
|
@ -0,0 +1,21 @@
|
|||
################################################################################
|
||||
#
|
||||
# 2048
|
||||
#
|
||||
################################################################################
|
||||
|
||||
2048_VERSION = 72725bab07d7686e5e5b3f68e398f43ffb6f49ce
|
||||
2048_SITE = $(call github,mevdschee,2048.c,$(2048_VERSION))
|
||||
2048_LICENSE = MIT
|
||||
2048_LICENSE_FILES = LICENSE
|
||||
2048_DEPENDENCIES = ncurses
|
||||
|
||||
define 2048_BUILD_CMDS
|
||||
$(TARGET_CC) -o $(@D)/2048 $(@D)/2048.c
|
||||
endef
|
||||
|
||||
define 2048_INSTALL_TARGET_CMDS
|
||||
$(INSTALL) -D -m 755 $(@D)/2048 $(TARGET_DIR)/usr/bin/2048
|
||||
endef
|
||||
|
||||
$(eval $(generic-package))
|
7
package/2048/Config.in
Normal file
7
package/2048/Config.in
Normal file
|
@ -0,0 +1,7 @@
|
|||
config BR2_PACKAGE_2048
|
||||
bool "2048"
|
||||
select BR2_PACKAGE_NCURSES
|
||||
help
|
||||
Console version of the game "2048" for GNU/Linux
|
||||
|
||||
https://github.com/mevdschee/2048.c
|
11
package/robotfindskitten/0001-execgamesdir.patch
Normal file
11
package/robotfindskitten/0001-execgamesdir.patch
Normal file
|
@ -0,0 +1,11 @@
|
|||
--- a/src/Makefile.in 2019-08-04 20:02:11.495635471 -0500
|
||||
+++ b/src/Makefile.in 2012-12-21 13:56:49.000000000 -0600
|
||||
@@ -199,7 +199,7 @@
|
||||
top_build_prefix = @top_build_prefix@
|
||||
top_builddir = @top_builddir@
|
||||
top_srcdir = @top_srcdir@
|
||||
-execgamesdir = $(prefix)/games
|
||||
+execgamesdir = $(prefix)/bin
|
||||
AM_CPPFLAGS = -DSYSTEM_NKI_DIR=\"$(datadir)/games/robotfindskitten\"
|
||||
robotfindskitten_SOURCES = robotfindskitten.c
|
||||
SPLINT_SUPPRESSIONS = +charintliteral +charindex
|
7
package/robotfindskitten/Config.in
Normal file
7
package/robotfindskitten/Config.in
Normal file
|
@ -0,0 +1,7 @@
|
|||
config BR2_PACKAGE_ROBOTFINDSKITTEN
|
||||
bool "robotfindskitten"
|
||||
select BR2_PACKAGE_NCURSES
|
||||
help
|
||||
A Zen simulation.
|
||||
|
||||
http://robotfindskitten.org/
|
18
package/robotfindskitten/robotfindskitten.mk
Normal file
18
package/robotfindskitten/robotfindskitten.mk
Normal file
|
@ -0,0 +1,18 @@
|
|||
################################################################################
|
||||
#
|
||||
# robotfindskitten
|
||||
#
|
||||
################################################################################
|
||||
|
||||
ROBOTFINDSKITTEN_VERSION = 2.7182818.701
|
||||
ROBOTFINDSKITTEN_SITE = http://robotfindskitten.org/download/POSIX
|
||||
ROBOTFINDSKITTEN_LICENSE = GPL-2.0
|
||||
ROBOTFINDSKITTEN_LICENSE_FILES = COPYING
|
||||
ROBOTFINDSKITTEN_DEPENDENCIES = ncurses
|
||||
|
||||
define ROBOTFINDSKITTEN_INSTALL_NKI
|
||||
$(INSTALL) -Dm644 "$(@D)/nki/vanilla.nki" "$(TARGET_DIR)/usr/share/games/robotfindskitten/vanilla.nki"
|
||||
endef
|
||||
ROBOTFINDSKITTEN_POST_INSTALL_TARGET_HOOKS += ROBOTFINDSKITTEN_INSTALL_NKI
|
||||
|
||||
$(eval $(autotools-package))
|
16
package/rogue/0001-fix-build-from-archlinux.patch
Normal file
16
package/rogue/0001-fix-build-from-archlinux.patch
Normal file
|
@ -0,0 +1,16 @@
|
|||
diff --git a/mdport.c b/mdport.c
|
||||
index 72fdbb7..5ff523e 100644
|
||||
--- a/mdport.c
|
||||
+++ b/mdport.c
|
||||
@@ -259,9 +259,10 @@ md_hasclreol()
|
||||
{
|
||||
#if defined(clr_eol)
|
||||
#ifdef NCURSES_VERSION
|
||||
+TERMTYPE *tp = (TERMTYPE *) (cur_term);
|
||||
if (cur_term == NULL)
|
||||
return(0);
|
||||
- if (cur_term->type.Strings == NULL)
|
||||
+ if (tp->Strings == NULL)
|
||||
return(0);
|
||||
#endif
|
||||
return((clr_eol != NULL) && (*clr_eol != 0));
|
7
package/rogue/Config.in
Normal file
7
package/rogue/Config.in
Normal file
|
@ -0,0 +1,7 @@
|
|||
config BR2_PACKAGE_ROGUE
|
||||
bool "rogue"
|
||||
select BR2_PACKAGE_NCURSES
|
||||
help
|
||||
The original dungeon crawl game
|
||||
|
||||
http://www.roguebasin.com/index.php?title=Rogue
|
18
package/rogue/rogue.mk
Normal file
18
package/rogue/rogue.mk
Normal file
|
@ -0,0 +1,18 @@
|
|||
################################################################################
|
||||
#
|
||||
# rogue
|
||||
#
|
||||
################################################################################
|
||||
|
||||
ROGUE_VERSION = 5.4.4
|
||||
ROGUE_SITE = https://github.com/phs/rogue/archive
|
||||
ROGUE_SOURCE = v$(ROGUE_VERSION).tar.gz
|
||||
ROGUE_LICENSE = Custom
|
||||
ROGUE_LICENSE_FILES = LICENSE.TXT
|
||||
ROGUE_DEPENDENCIES = ncurses
|
||||
|
||||
ROGUE_CONF_OPTS = \
|
||||
--enable-scorefile=/root/.rogue.scr \
|
||||
--enable-lockfile=/tmp/rogue.lck \
|
||||
|
||||
$(eval $(autotools-package))
|
38
patches/rogue/0001-ignore-setgid-if-unsupported.patch
Normal file
38
patches/rogue/0001-ignore-setgid-if-unsupported.patch
Normal file
|
@ -0,0 +1,38 @@
|
|||
diff --git a/mdport.c b/mdport.c
|
||||
index 72fdbb7..6f90ebb 100644
|
||||
--- a/mdport.c
|
||||
+++ b/mdport.c
|
||||
@@ -29,6 +29,7 @@
|
||||
SUCH DAMAGE.
|
||||
*/
|
||||
|
||||
+#include <errno.h>
|
||||
#include <stdlib.h>
|
||||
#include <string.h>
|
||||
|
||||
@@ -377,8 +378,10 @@ md_normaluser()
|
||||
#else
|
||||
if (0) {
|
||||
#endif
|
||||
- perror("Could not drop setgid privileges. Aborting.");
|
||||
- exit(1);
|
||||
+ if(errno != ENOSYS) {
|
||||
+ perror("Could not drop setgid privileges. Aborting.");
|
||||
+ exit(1);
|
||||
+ }
|
||||
}
|
||||
|
||||
#if defined(HAVE_SETRESUID)
|
||||
@@ -390,8 +393,10 @@ md_normaluser()
|
||||
#else
|
||||
if (0) {
|
||||
#endif
|
||||
- perror("Could not drop setuid privileges. Aborting.");
|
||||
- exit(1);
|
||||
+ if(errno != ENOSYS) {
|
||||
+ perror("Could not drop setuid privileges. Aborting.");
|
||||
+ exit(1);
|
||||
+ }
|
||||
}
|
||||
#endif
|
||||
}
|
Loading…
Reference in a new issue