Use my patched U-Boot v2019.04
This commit is contained in:
parent
dfef4a64d3
commit
afa9fd28ee
4 changed files with 54 additions and 35 deletions
|
@ -47,8 +47,8 @@ BR2_TARGET_ROOTFS_SQUASHFS4_XZ=y
|
|||
BR2_TARGET_UBOOT=y
|
||||
BR2_TARGET_UBOOT_BUILD_SYSTEM_KCONFIG=y
|
||||
BR2_TARGET_UBOOT_CUSTOM_GIT=y
|
||||
BR2_TARGET_UBOOT_CUSTOM_REPO_URL="git://github.com/Lichee-Pi/u-boot.git"
|
||||
BR2_TARGET_UBOOT_CUSTOM_REPO_VERSION="013ca457fd64b72444a0f5f480b1bbdd8b7481eb"
|
||||
BR2_TARGET_UBOOT_CUSTOM_REPO_URL="git://github.com/thirtythreeforty/u-boot.git"
|
||||
BR2_TARGET_UBOOT_CUSTOM_REPO_VERSION="e9a861c19c620224f5c1224cd7033b02adb8fa4d"
|
||||
BR2_TARGET_UBOOT_USE_CUSTOM_CONFIG=y
|
||||
BR2_TARGET_UBOOT_CUSTOM_CONFIG_FILE="$(BR2_EXTERNAL_BUSINESSCARD_PATH)/board/businesscard/v1/uboot_defconfig"
|
||||
BR2_TARGET_UBOOT_NEEDS_DTC=y
|
||||
|
|
24
patches/uboot/0001-HACK-businesscard-dtb.patch
Normal file
24
patches/uboot/0001-HACK-businesscard-dtb.patch
Normal file
|
@ -0,0 +1,24 @@
|
|||
From 9cc484071b0ed5f7d5ed411827ab8e908c2bee00 Mon Sep 17 00:00:00 2001
|
||||
From: George Hilliard <thirtythreeforty@gmail.com>
|
||||
Date: Sun, 16 Jun 2019 14:40:47 -0500
|
||||
Subject: [PATCH 1/2] HACK businesscard dtb
|
||||
|
||||
---
|
||||
arch/arm/dts/Makefile | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/arch/arm/dts/Makefile b/arch/arm/dts/Makefile
|
||||
index 0e2ffdb87f0..004bc39d918 100644
|
||||
--- a/arch/arm/dts/Makefile
|
||||
+++ b/arch/arm/dts/Makefile
|
||||
@@ -688,6 +688,7 @@ dtb-$(CONFIG_ARCH_MEDIATEK) += \
|
||||
mt7623n-bananapi-bpi-r2.dtb \
|
||||
mt7629-rfb.dtb
|
||||
|
||||
+dtb-y += businesscard.dtb
|
||||
targets += $(dtb-y)
|
||||
|
||||
# Add any required device tree compiler flags here
|
||||
--
|
||||
2.22.0
|
||||
|
|
@ -1,33 +0,0 @@
|
|||
From 4048a5c519a86eab2805f4f07fe9f5c6c8a1fe91 Mon Sep 17 00:00:00 2001
|
||||
From: Miquel Raynal <miquel.raynal@bootlin.com>
|
||||
Date: Thu, 16 Aug 2018 17:30:18 +0200
|
||||
Subject: [PATCH] mtd: declare MTD_PARTITIONS symbol in Kconfig
|
||||
|
||||
UBI selects MTD_PARTITIONS which is the symbol to compile
|
||||
drivers/mtd/mtdpart.c. Unfortunately, the symbol was not defined in
|
||||
Kconfig and this worked only with board files defining it. Fix this by
|
||||
adding a boolean in Kconfig so boards defined by defconfig files only
|
||||
will work as expected.
|
||||
|
||||
Signed-off-by: Miquel Raynal <miquel.raynal@bootlin.com>
|
||||
Reviewed-by: Boris Brezillon <boris.brezillon@bootlin.com>
|
||||
---
|
||||
drivers/mtd/Kconfig | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/drivers/mtd/Kconfig b/drivers/mtd/Kconfig
|
||||
index 9341d518f3e..d98457e2239 100644
|
||||
--- a/drivers/mtd/Kconfig
|
||||
+++ b/drivers/mtd/Kconfig
|
||||
@@ -1,5 +1,8 @@
|
||||
menu "MTD Support"
|
||||
|
||||
+config MTD_PARTITIONS
|
||||
+ bool
|
||||
+
|
||||
config MTD
|
||||
bool "Enable Driver Model for MTD drivers"
|
||||
depends on DM
|
||||
--
|
||||
2.21.0
|
||||
|
28
patches/uboot/0002-wtf-mmc.patch
Normal file
28
patches/uboot/0002-wtf-mmc.patch
Normal file
|
@ -0,0 +1,28 @@
|
|||
From 885f592f7ea2c607be5772db89712aa78b4510d6 Mon Sep 17 00:00:00 2001
|
||||
From: George Hilliard <thirtythreeforty@gmail.com>
|
||||
Date: Sun, 16 Jun 2019 15:56:06 -0500
|
||||
Subject: [PATCH 2/2] wtf mmc
|
||||
|
||||
---
|
||||
arch/arm/dts/sunxi-u-boot.dtsi | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/arch/arm/dts/sunxi-u-boot.dtsi b/arch/arm/dts/sunxi-u-boot.dtsi
|
||||
index fdd4c80aa46..d3abd4e8e3c 100644
|
||||
--- a/arch/arm/dts/sunxi-u-boot.dtsi
|
||||
+++ b/arch/arm/dts/sunxi-u-boot.dtsi
|
||||
@@ -1,9 +1,11 @@
|
||||
#include <config.h>
|
||||
|
||||
/ {
|
||||
+ /* WTF do you just assume we have an mmc?
|
||||
aliases {
|
||||
mmc1 = &mmc2;
|
||||
};
|
||||
+ */
|
||||
|
||||
binman {
|
||||
filename = "u-boot-sunxi-with-spl.bin";
|
||||
--
|
||||
2.22.0
|
||||
|
Loading…
Reference in a new issue